Administración de SaltOS

Questions: 24 (last: 01/02/2016)
Responses: 47 (last: 01/02/2016)

Sección dedicada para todas aquellas cuestiones relativas a cómo administrar SaltOS.

Nick: Carlos | Date: 20/02/2013 | Time: 09:29 | Responses: 4 (last: 20/02/2013)
Buenos días Josep,
de pronto esta mañana ha dejado de funcionar correctamente la gestión de usuarios asignados en cada grupo y los permisos por aplicación de dicho grupo. En el momento que entro a editar los usuarios asignados a un grupo desaparecen todos los que estaban asignados y aunque vuelva a seleccionarlos y actualice no los guarda. Lo mismo ocurre con los permisos por aplicación, pero en este caso no borra lo antiguo, simplemente no salva los cambios.
He intentado creando un grupo nuevo, pero nada, hace lo mismo.

Muchas gracias por tu atención.

Estoy utilizando SaltOS v3.1 r4767 sobre Ubuntu 10.04

Re: Usuarios y Grupos

Nick: Josep Sanz | Url: http://www.saltos.net | Date: 20/02/2013 | Time: 09:54
Buenos días Carlos.

Sabes si se ha actualizado el servidor???
Que versión de PHP se está usando ese Ubuntu???

El problema que creo que puedes tener es que en alguna actualización del servidor, se ha instalado la versión de PHP que usa el max_input_vars. Con las nuevas releases de saltos, este problema queda resuelto de forma transparente para el usuario, pero en la versión que comentas tener, deberás de editar el php.ini para hacer que el valor de la directiva max_input_vars sea de 10000 en lugar de 1000 como viene por defecto y reiniciar el servidor.

Puedes encontrar más info del problema en: http://www.saltos.net/portal/es/detalle/wiki/76/como-solucionar-la-limitacion-del-max-input-vars.htm

Nota: creo que es ese el problema, pero sin meter mano al server, no lo puedo garantizar.

Re: Usuarios y Grupos

Nick: Carlos | Date: 20/02/2013 | Time: 10:23
Hola de nuevo,
he estado revisando y tengo la versión 5.3.2 de PHP, no encuentro la directiva max_input_vars en php.ini, así que creo que no ha habido ninguna actualización como comentas. En fin no se que puede estar pasando.

Re: Usuarios y Grupos

Nick: Josep Sanz | Url: http://www.saltos.net | Date: 20/02/2013 | Time: 10:45
Buenas.

Intenta subir un archivo al servidor que se llame phpinfo.php y que contenga lo siguiente: <?php phpinfo(); ?>. Una vez subido, intenta ejecutarlo y te debería aparecer una página con toda la información del php de tu servidor. Si puedes, enviame por correo a josep.sanz@saltos.net la url para que yo lo vea. De esta manera te podré acotar el problema.

Josep.

Re: Usuarios y Grupos

Nick: Carlos | Date: 20/02/2013 | Time: 12:40
Resuelto; muchas gracias Josep.
Efectivamente aunque no lo veía el límite de max_input_vars estaba fijado en 1000, incluyendo la línea max_input_var = 20000 en la sección "Resource Limits" de php.ini, ha quedado resuelto el problema.

Una vez más muchísimas gracias.

PHP lines
15,501
JS lines
13,186
XSLT lines
2,498
XML lines
2,397
CSS lines
591
SQL lines
211