Requerimientos técnicos

Dependencias mínimas

Para aprovechar todo el potencial de SaltOS, el sistema que hospede el software debe satisfacer los siguientes requisitos mínimos:

  • Servidor web: Apache, Cherokke o Nginx
  • PHP 5.2 o superior: PHP 7 y HipHop también estan soportados
  • Soporte para MariaDB, el nuevo MySQL realmente libre, o SQLite3:
    • 2 drivers de SQLite3 mediante: Clase PDO y Clase SQLite3
    • 3 drivers de MariaDB (MySQL) mediante: Clase PDO, las funciones mysqli_* y las antiguas funciones mysql_*
  • Soporte extra para otras bases de datos:
    • 2 drivers para SQLServer (MsSQL) mediante: Clase PDO y las funciones mssql_*
  • Soporte para GD2 desde PHP (php-gd)
  • Soporte para procesado XSLT (php-xml)
  • Soporte para multy-byte (php-mbstring)

Dependencias extras

Además existen prestaciones adicionales que requieren el uso de ejecutables disponibles en otros paquetes:

  • unoconv: para convertir documentos de múltiples formatos a PDF empleando OpenOffice 3.0 o superior para el visor de PDF's online.
  • soffice:
  • pdftotext: para convertir los documentos PDF en texto plano para ser indexado en la base de datos
  • text2wave: para convertir el texto plano en audio para el sistema de notificaciones por voz
  • lame: para convertir de wav a mp3 para reducir el ancho de banda usado
  • apertium: para realizar traducciones entre pares de idiomas
  • aspell: para realizar correcciones de texto
  • which: para localizar los binarios para ejecutarlos
  • pdftoppm: para convertir los documentos PDF en imagenes para ser procesados por tesseract.
  • convert: para convertir imágenes a formatos conocidos.
  • tesseract: software de OCR para obtener texto de imágenes.
  • timeout: para controlar el tiempo de ejecución de los comandos.


Líneas de XML
54,132
Líneas de PHP
13,746
Líneas de JS
6,178
Líneas de T2T
3,497
Líneas de XSLT
2,507
Líneas de SQL
1,483